Stella SW drag problem???

Discussion in '360 Degrees Lounge' started by rhale, Jun 29, 2009.

  1. rhale

    rhale Senior Member

    361
    2
    I fished my new 10K SW this past weekend and something is wrong with the drag. I have only caught maybe 5 fish on it and it worked fine untill this trip. It is very sticky and jerky. When I pull line off with my hand I can feel it loosen dramaticaly after it breaks the start up drag.

    Is there something that I can check or change myself of do I need to send it in for service? The only reason I dont want to just send it in is because I will be fishing again in a few days and dont want to go without it. Thanks for any info.
     
  2. Van Wildonher

    Van Wildonher Member

    74
    0
    Last time I seen somebody with a jerky stella drag problem it was because water had got in the drag.
     

  3. Milton

    Milton Senior Member

    142
    0
    did you lock the drag when washing the reel? I heard water in the drag is one of the main cause to that problem.
     
  4. lordhell

    lordhell Moderator

    4,747
    61
    hey rhale, I also have a Stella 10kSW and bought a spare spool for it as well. I was checking the drags on both spools and was only able to max at 17 lbs with the cap ABSOLUTELY locked down, which is unacceptable for a Stella. I asked around and even looked into the drags myself but couldn't figure out the problem. I asked Shimano USA and they told me to send it in for service. I got my spools back after 1 week and was able to get around 30 lbs of drag on one spool and about 26 lbs of drag on the other. I would call that an improvement but that is still not good enough for me. My 8kSWPG spool easily exceeds 34 lbs of drag so I have no idea why the 10kSW spools have these isolated drag issues.

    My suggestion is for you to send it in and get it serviced from Shimano USA.
     
  5. bigscrnman

    bigscrnman Senior Member

    660
    0
  6. lordhell

    lordhell Moderator

    4,747
    61
    The thing is, I sent my reels back to Shimano USA and they serviced the drags already. Still I get only 26lbs on one of the spool, and that is with the cap locked down tight as can be. Well, atleast the other spool is getting 30lbs with the cap locked completely down... Dunno what's going on with these spools...
     
  7. SkeeterRonnie

    SkeeterRonnie Senior Member

    1,996
    42
    my first trial would be the grease on the drags deal. open it up and see whats up with the drags. maybe a piece of salt or debris in the drag stack.
     
  8. Muddskipper

    Muddskipper Senior Member

    176
    2
    I would send it back ASAP .... they should have a 48hr turn around on the Stellas
     
  9. rtran

    rtran Senior Member

    1,579
    3
    The thing is, I sent my reels back to Shimano USA and they serviced the drags already. Still I get only 26lbs on one of the spool, and that is with the cap locked down tight as can be. Well, atleast the other spool is getting 30lbs with the cap locked completely down... Dunno what's going on with these spools...

    the reels do not have the rated 50+lb drag with full spool.
    it is measured with empty spool which equates to 20-30lb drag at full spool
     
  10. rhale

    rhale Senior Member

    361
    2
    the reels do not have the rated 50+lb drag with full spool.
    it is measured with empty spool which equates to 20-30lb drag at full spool

    Thats interesting... Where did you get this info? Thats the first time I have heard that.

    It had plenty of drag before the problem but still good info.
     
  11. lordhell

    lordhell Moderator

    4,747
    61
    the reels do not have the rated 50+lb drag with full spool.
    it is measured with empty spool which equates to 20-30lb drag at full spool

    Yup, you're right about that. I hope that is the case, however, Baosabi's 10kSW spool at full achieved 34lb drag with room for more... so that leaves me wondering...
     
  12. rtran

    rtran Senior Member

    1,579
    3
    pametfisher had posted about the drag ratings in another thread before
     
  13. rhale

    rhale Senior Member

    361
    2
    I got to the drag washers and water intrusion is deffently my problem. I just dryed and cleaned everything and put it back together for now. I can tell its better but not fixed. I am sending it in for service. Thanks for all the info.
     
  14. SkeeterRonnie

    SkeeterRonnie Senior Member

    1,996
    42
    well then that would mean my spheros with 22# of drag at full spool would crater once I get down to around half... something would give.. I need to watch this, and back the drag off when I lose some line to a drag smoker.

    thanks for the info.