360 Tuna Fishers Forum banner
1 - 7 of 7 Posts

·
Senior Member
Joined
·
110 Posts
Discussion Starter · #1 ·
So toward the of my Panama trip I noticed my STL8000 SW was turning a little rough. It seems like an internal issue since it still feels rough when the spools off. Probably just need to send it back to Shimano for servicing but with all the Stella guys on the board just wondering if anyone has had a similar problem and if so what it ended up being the problem.

I fished the reel this way for a couple days and it didn't seem to really be an issue other than it just does not feel as smooth as I would expect and know it should.

Thanks!
 

·
Senior Member
Joined
·
2,753 Posts
I think willy had some issue before sounding like the same as yours...Billiam is his screen name...
 

·
Senior Member
Joined
·
2,622 Posts
wouldn't it still be under warranty? Either way I agree send it back to Shimano and if I had to guess it one of the almost ARB's.
 

·
Moderator
Joined
·
580 Posts
I have a stella SW 20k and the 2nd or 3rd time I used it up in cape cod I had some type of grinding sound. It sounded like a pepper grinder when I turned the handle. I tried unscrewing fully the handle shacking it for loose dirt or debris, but when I put it back, issue was still there. Even the Capt. Dom didn't know why it was happening. I called up Shimano, looking for their "platnium service" for the stella, but the guy I had on the phone didn't know a thing about it. He did however direct me to a Shimano certified servicing station in NYC area. When I went there, I handed my reel over and the service agent at in a tackle store put on the handle and turned it. For some reason the problem seemed to disapeared???? Making me look like a fool... ??? I told him the situation and thank him and he said I didn't do anything... My guess was that there was some salt or sand wedged into a crevice in the handle. My suggestion would be to try submerging the reel in luke warm water to try to dissolve salt or shake off some sand. And put it back together. I wouldn't try with soap or detergent as it may de-grease any parts internally if it seeps in. Good Luck with your situation wish I could help more. Let us know how things turn out.
 

·
Senior Member
Joined
·
110 Posts
Discussion Starter · #6 ·
Thanks guys. I intend on sending it in for servicing. Just wanted to hear if anyone else had a similar problem. Should have done it right after I got back from Panama and not waited till the BFT's moved in off the coast of VA/NC!!! I know right when I send it back a high pressure system will move in and the bite will turn on!
 
1 - 7 of 7 Posts
Top